Skip to main content
Topic: Highbeams stuck on. (Read 1337 times) previous topic - next topic

Highbeams stuck on.

No clue on how this happened, but my highbeams are stuck on. The switch on the dash is fine but I have had some problems with the turnsignal switch in the column before. I dont feel like paying almost $40 for a new t/s assembly. Does any one have a wireing diagram for this so I can see if I can run a seperate switch to it or something?
85 Tbird 5.0
78 F150 351w
03 Ranger Fx4

Re: Highbeams stuck on.

Reply #1
Here's part of a post from our previous Coolcats forum:

-----------------------------------------------
>IF< it's the same problem I had, the high-low switch inside the signal assembly (the part that goes click when you pull on the lever) is crap. There's a tiny little spring-loaded metal contact strip in there that, on mine, overheated and melted the surrounding plastic enough to keep the strip from making contact.

I first noticed that I had to click a few times to get my low beams back after using the highs. Eventually low beam wouldn't work at all. I took the switch apart, carved away the melted bits, and it worked for a week or so. Then it melted beyond all help, and the switch no longer "clicked", as the whole thing had been turned into a shapeless blob.

For a temporary solution, I cut the Red/Yellow and Red/Black wires leading to the switch (did I mention the plug had also been partially melted by the heat from the bad contacts?), and hooked them together. I now have low beams, but no highs unless (like you) I hold the lever in the "pass" position.

Someday I'll get out there and replace the turn/hazard/high/low switch assembly (I already have another one), and at the same time install relays for the headlight to reduce the current going through the dimmer switch, so it'll never happen again.
-----------------------------------------------
Death awaits you all with nasty, big, pointy teeth.

1988 5.0 Bird, mostly stock, partly not, now gone to T-Bird heaven.
1990 Volvo 740GL. 114 tire-shredding horsies, baby!

Re: Highbeams stuck on.

Reply #2
Thanks for the info. I'll try that out tomarrow.
85 Tbird 5.0
78 F150 351w
03 Ranger Fx4

Re: Highbeams stuck on.

Reply #3


See the green thing on the TS switch?  Push it firmly to the right a few times.  If the lights switch from high to low & back, then follow the linkage from the lever to the green thing.  See the little steel pin that's parallel to the column?  The thing my pin rides in is shattered, so I have to use the green thing for a dimmer.

I wanna put mine on the floor where it belongs!:D

Re: Highbeams stuck on.

Reply #4
Wanna hear something funny. Apperantly the previous owner replaced the switch assy. cause my green thing aint green, its white. I also looked inside it, pulled the lever, it clicked, and saw the switch thing inside move like its supposed to but the highs are still on. Right now I'm rather confused on whats goin on with it. I'm not sure if I want to do the wire thing or not cause the switch is fine. Any ideas on whats goin on with this?
85 Tbird 5.0
78 F150 351w
03 Ranger Fx4

Re: Highbeams stuck on.

Reply #5
well, first off,,,,
when you gently pull back on the lever ****just before it locks high beam in****

do you hear a relay click (location of click would be lower right hand underside of dash)

if not,

the relay is not getting power and your switch you mention might actually be defective although you do see it move and hear a click sound.

use a meter to be sure.