Skip to main content
Topic: Cruise control quit working (Read 105 times) previous topic - next topic

Cruise control quit working

88 5.0 AOD

I will check the fuses when I get home. Other than that I have no idea what else to check.  I've never messed with the cruise stuff before.  Any advise is appreciated. 
Mike

 

Re: Cruise control quit working

Reply #1
Does the horn work?
Do the brake lights work?
Can you hear a vacuum leak by the brake pedal?

Re: Cruise control quit working

Reply #2
The voltage at the horn switch in the steering wheel is used by the cruise control buttons on the steering wheel.
If the horn works it confirms the voltage is available at the steering wheel.

There is a vacuum operated servo under the drivers side fender. It pulls on a cable attached to the throttle.
You remove the left front wheel and fender liner to access it. The cable may have disconnected from the servo.

 There are two vacuum  hoses to the servo. They go through a hole by the brake booster to get to the servo under the fender.
The vacuum source hose (brown stripe) and the dump valve hose (white stripe)

The dump valve is on the brake pedal and opens when the pedal is pushed. No vacuum no cruise control.
You can disconnect  dump hose (near the brake booster) and suck on the hose to the dump valve to see if there is a vacuum leak.

The dump valve is a safety devise to guard against a "run away" cruise control if the electronics go crazy!!

Re: Cruise control quit working

Reply #3
Pics from 84 Shop Manual.
84 is CFI so the throttle hook-up will be different on your car.

Re: Cruise control quit working

Reply #4
Thank you!  I will check this out this weekend.  I know I do have horn.  :smile:
Mike

Re: Cruise control quit working

Reply #5
Check the rings on the back of the wheel as well. If they are damaged the cruise won't function.
88 Thunderbird LX: 306, Edelbrock Performer heads, Comp 266HR cam, Edelbrock Performer RPM intake, bunch of other stuff.

Re: Cruise control quit working

Reply #6
Horn works, guess there is power to the rings

Brake lights work, switch and wiring is good on the pedal switch. 

The plunger thing against the pedal looks good and is making contact against the pedal arm

Everything else is working in the car, so I don’t think it’s a fuse issue. 

Guess I need to tear into the fender

When you push the brake pedal slightly when the car is off, should you hear vacuum bleed off???   Cause I did.
Mike

Re: Cruise control quit working

Reply #7
Don't know about the dump hose holding vacuum after the engine is shut down.

Fuse 17 is the fuse for the cruise control amplifier.

There is a procedure for testing the servo.
It involves measuring the resistance of the servo solenoids and jumpering voltage and grounds to the solenoids to make it rev the engine.  If you want to try that, I will post more details.

Re: Cruise control quit working

Reply #8
I will check that fuse, but everything else on that circuit is working. 

I will just take the tire and splash guard out and see if that cable is attatched.
Mike

Re: Cruise control quit working

Reply #9
Does the speedometer work? If you have an electronic speedometer, it provides the speed info to the cruise control amplifier. You have to be above 25mph (I think) for the cruise to work.

Re: Cruise control quit working

Reply #10
Yes, I have the full digital cluster and the speedo works.  Cruise just quit out of the blue, was working fine prior and I didn't work on anything or move anything to disturb anything.
Mike