Skip to main content
Topic: Porting the Edelbrocks...Heads and Lower Intake (Read 10670 times) previous topic - next topic

Porting the Edelbrocks...Heads and Lower Intake

Reply #30
Well, I got the valve covers on and the injectors and fuel rails mounted.  The valve covers were nasty and needed some polishing so that pretty much killed a couple of hours but they look a lot better.  Got the ACT and coolant temperature senders in the intake as well as the temperature sending units for the stock gauge and the Autometer gauge.

Valve Cover Gasket:


Valve Covers Installed:


Fuel Injectors and Fuel Rail:


Also took a picture down the intake runner from the top of the lower intake, pretty  good match if you ask me:



Ended up killing a couple more hours today making a positive stop for the piston so I can get the car up on TDC to stab the distributor.  I can post up some pics on this little tool if anyone is interested.  Does not take much to make and works really well.

Darren

83 351W TKO'd T-Bird on the bottle


93 331 Mustang Coupe - 368 rwhp

Porting the Edelbrocks...Heads and Lower Intake

Reply #31
Good lookin' mill.
You used the Fel Pro reusable v/c gaskets, I take it? I think they have a steel core in them?
I've got a set to go on one of the 5.0s, both of them need v/c gaskets, oil leakers that they are.

Those gaskets are nice..I'd recommend 'em over about anything else.
'84 Mustang
'98 Explorer 5.0
'03 Focus, dropped a valve seat. yay. freakin' split port engines...
'06 Explorer EB 4.6

Porting the Edelbrocks...Heads and Lower Intake

Reply #32
I love motor porn

Porting the Edelbrocks...Heads and Lower Intake

Reply #33
Yes, steel core and very good with regards to leaks.  These were on the car for over five years but I only had about 10,000 miles on it.  Too much work and not enough play time.  They cleaned right up with some brake cleaner on a rag and I let them set overnight to make sure anything they soaked in flashed off.

Darren

83 351W TKO'd T-Bird on the bottle


93 331 Mustang Coupe - 368 rwhp

 

Porting the Edelbrocks...Heads and Lower Intake

Reply #34
Well I got a bit further with getting the flywheel installed, RAM clutch assembly installed, and got the bell housing & clutch fork installed as well.

Center Force flywheel installed:


RAM clutch disc and alignment tool installed:


RAM pressure plate installed:


Clutch fork and RAM throw out bearing installed into bell housing:


Bell housing installed:



I finally was able to locate a timing pointer at Tommie Vaughn Ford (P/N F1TZ-6023-A in case anyone ever needs that) and got it installed and TDC verified on the motor.  I used a positive stop device my dad taught me how to make years ago and the ATI was on the money with TDC.  I painted the edge of the timing pointer and the 10 Degree mark on the balancer white so it would be easier to time the motor.  I have a SCT chip so the tune requires a 10 Degree baseline.

Positive stop device:


Pointer and balancer marked:



Hopefully the weather will cooperate tomorrow and it will be warm enough to open the garage door so I can get the motor put in and then push it back in the garage to install the tranny, clutch cable, drive shaft, exhaust, and shifter.  From there its all engine bay work and installing the hood.

Darren

83 351W TKO'd T-Bird on the bottle


93 331 Mustang Coupe - 368 rwhp

Porting the Edelbrocks...Heads and Lower Intake

Reply #35
Lookin' good.
Your tool, made from a hollowed out plug and a piece of all thread?
'84 Mustang
'98 Explorer 5.0
'03 Focus, dropped a valve seat. yay. freakin' split port engines...
'06 Explorer EB 4.6

Porting the Edelbrocks...Heads and Lower Intake

Reply #36
Very nice

Porting the Edelbrocks...Heads and Lower Intake

Reply #37
That it is.  Hollow out the plug, drill it with a 5/16" bit, tap it with a 3/8-16 tap (use lots of WD40 or the like and take small steps as it gets tight), a six inch piece of 3/8-16 all thread, and (1) 3/8-16 jam nut.  Works like a champ and costs about $5 if you use an old plug from a recent tune up.

Darren

83 351W TKO'd T-Bird on the bottle


93 331 Mustang Coupe - 368 rwhp

Porting the Edelbrocks...Heads and Lower Intake

Reply #38
Last picture post as it is just the installed motor.



It may be a couple of weeks before I can get it on the dyno and tuned but I will post up the numbers when that happens.

Darren

83 351W TKO'd T-Bird on the bottle


93 331 Mustang Coupe - 368 rwhp

Porting the Edelbrocks...Heads and Lower Intake

Reply #39
Nice is that a plate between the intake or just a spacer ?


I should start a thread on my project mustang .......... Just thought I would get kicked out lmfao

Porting the Edelbrocks...Heads and Lower Intake

Reply #40
Looking good...after the 50+ degree odd January weather day....I needed to look at some engine porn.

Travis

Porting the Edelbrocks...Heads and Lower Intake

Reply #41
It's a 1" billet spacer to clear the taller valve covers needed to clear the girdles on the valve train. Got it from a machinist on the Corral that makes them himself. Like to buy from car guys if I can. 

Darren

83 351W TKO'd T-Bird on the bottle


93 331 Mustang Coupe - 368 rwhp

Porting the Edelbrocks...Heads and Lower Intake

Reply #42
So I wanted to update this thread with the corner's report on my 331.  The motor had a top side ticking noise from day one and I just chalked it up to noisy roller lifters as everyone else on the web was also bitching about the lack of quality in almost every brand of OEM lifter replacement.  What had me miffed it that the cam, lifters, push rods, rockers, and complete heads were off the old 306 and it had no top side noise what so ever.  I adjusted the valves about six times on the Ford Racing lifters and then replaced them with a set of Comp Cams lifters only to find that they too ticked.  It was soon after this I parked the car for over a year as I was just fed up with it and did not have the time to dig into it.

So I pulled the 331 out of the Coupe a little over three months ago and took it to a friend of mine that is a machinist and engine builder.  He remembered the motor as he did all the machining and balancing and I told him to just use it as filler work which usually gets me a better deal being I was not needing it done right then and there.  I am 100% sure he did zilch wrong and I will take the blame for all of this being I assembled the engine. After he tore the motor down and did the autopsy he found that the cam bearing had failed but he was miffed as to what caused it.  It appears that the cam bearing failures were just bad bearings which pretty much did the bulk of the damage.  The bearings failed in a very odd way in that it was the driver side on all of them that kind of smeared and plugged the oil port.  This explains the drop in oil pressure the last couple of months the car was running.  The crank also had enough scarring on the main and rod bearing surfaces that it had to be ground and polished but it was a brand new SCAT crank so it only took a ten/ten grind and polish and it was back to shiny new.  We are attributing the cam bearing material and plugged ports as the cause of the crank scarring.

He checked the distance between the pan and oil pump pick up screen and it was good but he did tell me what that minimum distance was supposed to be and that got clayed when I built it so I knew that was good to go.  He then checked the oil baffle doors in the Canton road race pan and found two of the three were stuck shut due to the hinge mechanism being messed up.  He fixed those and then just put that fix on the other one that worked to make sure it would not have an issue later down the road.  Again, cannot bitch here as this pan was a prototype off of a Maximum Motorsports road race car and I bought it from the guy at MM when he went to a 351W.  He also tore the blue printed oil pump down and it was good to go so he put it back together and put it on his oil pump dyno (this guy builds some cool stuff) and bumped the pressure up a little bit as I did not like that is was at 30 psi at idle.  I am more of a 40 psi idle and 90 psi at 6,000 rpm.  It eats a little hp but I think the added benefit for the long haul is worth loosing a couple ponies.

He then moved to the cam and looked it over and it is good to go but has a little wear on the distributor gear which neither one of us completely understand as I am running a bronze distributor gear like I always do on roller sticks.  So I have researched this a little more and am going to switch to a Crane Cam steel gear as it is compatible with all steel camshaft cores made of either induction hardened or carburized steel.  This will ensure that I have the right gear and it will not wear out like a bronze one.

So we moved up to the lifters and he did not like how large the oil passage was on the Comp Cam lifters so I boxed them up and they are going back to Comp to see if they machined them incorrectly.  What directed him to look at the oil passage was the fact that with the valve covers off and just priming the motor with a drill the top side of the heads were just getting flooded with oil.  I brought him the Ford Racing lifters I built the motor with and after some examination he requested new ones as those had excessive wear.  These came out of the 306 before this 331 so they did have about 16,000 miles on them but still that seemed a short life.  I did a little research on lifters and found out that Ford redesigned their OEM style lifter a few years ago and they were now good to 6,400 rpm.  I ordered a set of these (P/N M-6500-R302H) and he liked them so they got installed.

Now that he had the short block done and the cam and lifters installed he moved to the heads and looked them over.  Everything looked good so he just lapped the valves and seats and put them together.  Upon assembling them he found that the roller rockers (Crane Energizer 1.6's) were hitting the spring retainer but just a fuzz so he machined all 16 of the rockers.  Interesting thing is they already had reliefs but we attributed the contact to using the Manley Titanium retainers as they appear to be just a fuzz larger in diameter than stockers.  Now that the heads were assembled those got installed onto the block with FelPro gaskets and ARP studs.  Now came the critical part that I suspected was the main culprit in my top end noise and that was the push rods.  Sure as shiznit my stock Ford Racing units were 6.250" long and I needed 6.1" length...I patterned those  things when I built it but evidently missed it.  Lesson learned here was to ask him for a pair of solid roller lifters to put in my tool box and toss the old hydraulic ones I had that were tack welded.  You have to measure push rod length with solid rollers as the hydraulic ones are not pumped up.  Ended up getting TrickFlo pushrods as they were the only brand name I recognized that were in stock at Summitt and had them drop shipped.

So now he was up to installing the intake and the one he had would not fit between my Edelbrock Performer RPM heads and he was swearing up and down my head were milled.  Nope, stock Edelbrock Performer RPM lower bolts up as well as my buddies Vic Jr. so that was another weird deal but we used the Vic Jr on the dyno.  He used a 650 CFM Holley for the carburetor and I borrowed a buddy's stock '85 Mustang distributor for the dyno session.  Found out later that it was another customer's Parker intake (I know this guy and he offered to let us use the intake) that was brand new and evidently you have to mill them to fit but I an not sure about that.

First whack at the dyno and the motor made 402fwhp / 368 ft-lbs of torque.  He did a little tuning on the carb and ran it again, made 452 fwhp / 410 ft-lbs of torque.  He said it has more but didn't want to mess with it being its an injected motor.  Hoping to get it back in the car in the next couple of months and get it dyno tuned.  I'll post up the final numbers when I get that done.

83 351W TKO'd T-Bird on the bottle


93 331 Mustang Coupe - 368 rwhp

Porting the Edelbrocks...Heads and Lower Intake

Reply #43
Nice numbers. Always fun to play with a 3 dimensional jigsaw puzzle...can't wait to see the pics, Darren.
'84 Mustang
'98 Explorer 5.0
'03 Focus, dropped a valve seat. yay. freakin' split port engines...
'06 Explorer EB 4.6

Porting the Edelbrocks...Heads and Lower Intake

Reply #44
Aerocoupe- sounds like the 5.0 I  just built for the Turbo Coupe. For awhile I was calling it the motor from hell. Found the first problem after the machine shop when I had the motor together and was pre-lubing it. Wasn't getting oil to the rockers and was hearing a gurgling sound. Started looking around and found a missing galley plug behind the distributor shaft. Tore it all back down and back to the machine shop it went. They were "very sorry", installed a new plug and gave me new gaskets. Back to assembly. Got the motor put back together and in the car, clutch, pressure plate, trans installed. It's a tight fit with equal length shortie headers. Put a 1/4 in spacer under the mounts so the Hamburger oil pan would clear the steering rack. Next morning found a puddle of oil under the rear of the motor. Pulled everything off and found a dent in the gasket the machine shop gave me. Motor back out. Replace the gasket. Motor back in. Got everything hooked up, all fluids in. Tried to start it and it wouldn't fire. Found a bad wire between the TFI and coil. Tried to fire it and it started real ragged. Shut it down. Found a bad coil wire- new MSD 8.5's. Started it again. Messed up idle but it was running. Then I saw the distributor turn towards the A/C bracket and car stalled. WTF! Yes the clamp was tight. Pulled the distributor and found the shaft had seized. A new MSD Pro Billet distributor. Put the stock one back in. Car started and after it warmed up had a descent idle, no leaks. Car ran for an hour and decided to take it for a test run. My new power steering pump was making a milkshake out of the oil but drove it anyway. Test drive was a success. My buddy took it for a drive and it quit running 100yds from his shop. towed it back. Found out that the new Quantum 255lph pump quit. Replaced the power steering pump, installed a new Walbro 255lph pump. MSD repaired or replaced the distributor, should have it back today. Car is running pretty good- 14* timing, 40lb fuel pressure, idle at 900. Car has 62 miles on it now- street and freeway- no problems. I'll take it to the dyno after break in. It's a trip to drive.
1987 Turbo Coupe, 306, Trick Flow Track Heat heads, Comp Cam, Trick Flow Pistons, Eagle Rods, Center Force clutch, T-5, 8.8 w/373 gears, and a bunch more