Skip to main content
Topic: Rehabbing an 87 Turbo Coupe (Read 125 times) previous topic - next topic

Rehabbing an 87 Turbo Coupe

Hey all, was a (fairly inactive member) years ago, for the last year or two I've been utilizing all the information here I could find so I figured it was time to get off my rear and join again.

I have an 87 Turbo Coupe, it was my first car that I bought when I was fifteen for $3,300 in 1994.  We grew up drag racing, so between my junior and senior year my dad and I pulled out the four cylinder and automatic and dropped in a 351 and a T5.  Over the next several years it went through several iterations winding up with a 408 and a Tremec.  During that time there were plenty of bad decisions, rushed mods, bad wiring techniques, the usual I guess.

Over time I also got into sportbikes, ATVs, then kids came along, so the car kind of got neglected.  A while back I got it back on the road again, but it wound up getting hot and stretched the head bolts.  I pulled the heads, then remembered how much I hate doing engine stuff with it in the car, decided to pull it, then got distracted....So this is how it sat for a while:





When I turned 40 a couple of years ago, I got on a big fitness kick, which then led to having more energy, which led to picking up hobbies again.  First I went through my sportbike, then I turned my attention to the Thunderbird.  I pulled the motor, got it reassembled and repainted.






Re: Rehabbing an 87 Turbo Coupe

Reply #1
Figured I'd post as a start before I went too far and had formatting screwed up or something.  Anyways...

From there I dove into the brake system.  Years ago I'd put a regular mustang master cylinder and booster on it, which as everyone knows was a mistake.  So through lots of note taking from here I went with the usual 93 cobra stuff and a wilwood proportioning valve.  I'd never messed with brakes before, so learning to bend and flare lines was satisfying.  I'll return to that later...

Once the brake system was back together, my dad came over and we dropped the motor back in.



From there, I probably spent a couple of weeks on the front dress, refinishing everything I could, replacing all hardware etc.  I've tried hard to clean/paint/replace everything I've gotten my hands on during this process.





Now if you're eagle eyed, you may see one problem.  That proportioning valve and lines made it royal hell working on that side of the motor (ironically why I ditched the factory setup to start with) so I got to redo all of that.  I'll have to get a photo of that work.

From there, all fluids were added and went to check to see if it was ready for startup.  No fuel pump whine on key on...

Re: Rehabbing an 87 Turbo Coupe

Reply #2
Good looking car!  That all fit under the stock hood?

Did the inertia switch in the trunk get tripped?
1988 Thunderbird TC, 5spd
Stinger 3" single exhaust, Cone Filter, Adjustable Cam Pulley, Schneider roller cam, Walbro 255 lph,
'93 Mustang Cobra replica wheels on 235/50R17

'16 F150 XLT 5.0
'17 Husqvarna TX300

Re: Rehabbing an 87 Turbo Coupe

Reply #3
Sorry, need to pick the timeline back up.  Fingers crossed on it fitting, the air cleaner is basically the same height as my old one, which did clear, but it comes a little farther forward.

Some time ago I had had the fuel tank sumped by a local guy who is a well known racer and originally a welder.  Unfortunately he did an awful job and I had to seal it up.  From there it went to a Mallory 110 external pump.  The gerotor was stuck and the brushes were disintegrating (not the first time I've changed them).  I've never been happy with the setup, and was actually getting some fumes from the tank when I added gas a few weeks ago, so when the gerotor still wouldn't turn after replacing the brushes I decided to scrap the whole thing and start over.

I ordered a new fuel tank, aeromotive phantom 200 retrofit kit, aeromotive regulator, and lines and fittings for a return line (I already had PTFE braided line for the supply, deadheaded at a holley regulator.  Not great I know).  I wanted to start over with a new hat versus trying to modify the factory one.  Turns out that it takes very little work to get it in the stock location.









After test fitting it I pulled everything back out, then undercoated the tank the last two nights.  Next couple of days will be finishing the fuel system (have a few last fittings coming Thursday) and hopefully trying to fire it this weekend.  I'll fill in the gaps as time goes on, this was kind of a broad strokes start to the process.

There's also a decent bit of electrical troubleshooting still to be done, I've been working my way through that.  Ignition switch was bad, looks like I have a bad driver side power door lock switch, the wipers aren't returning to the park location so it buzzes when the wipers are turned off...  Definitely a work in progress.

Re: Rehabbing an 87 Turbo Coupe

Reply #4
That is a GREAT looking car!
Mike

 

Re: Rehabbing an 87 Turbo Coupe

Reply #5
Thank you sir, I'll get better photos as it goes back together.  Just doing this thread made me actually start organizing my pictures.

Re: Rehabbing an 87 Turbo Coupe

Reply #6
Wipers not parking?

The wiper motor is shot.

You got this.. :ford: :birdsmily:
'84, '87 Mustangs
'98 Explorer 5.0
'06 Explorer EB 4.6
'11 Expedition EL

Re: Rehabbing an 87 Turbo Coupe

Reply #7
Got the lines under the hood done, lines to the tank are connected to the bulkhead fittings in the fenderwell and the fuel filter on the frame rail.  Tomorrow morning I'll get the tank in position, run the lines to it and mark them, cut and terminate them, re run the fuel pump wires, and hook everything to the tank.  Shooting for Sunday morning startup.





Plug wires need some organization, I moved them around to bolt down the valve covers.

Re: Rehabbing an 87 Turbo Coupe

Reply #8
It's pretty cool that you were able to hold onto your first car for all of these years.

At one point, I was wondering if it would be possible to do an aftermarket fuel pump and hanger like that. I'm glad to see it actually works
It's Gumby's fault.

Re: Rehabbing an 87 Turbo Coupe

Reply #9
I actually still have my first vehicle, as well as my first car.
'74 Jeep J10 and the car is an Escort GT, an '86.

'84, '87 Mustangs
'98 Explorer 5.0
'06 Explorer EB 4.6
'11 Expedition EL

Re: Rehabbing an 87 Turbo Coupe

Reply #10
Did it start?
1988 Thunderbird TC, 5spd
Stinger 3" single exhaust, Cone Filter, Adjustable Cam Pulley, Schneider roller cam, Walbro 255 lph,
'93 Mustang Cobra replica wheels on 235/50R17

'16 F150 XLT 5.0
'17 Husqvarna TX300

Re: Rehabbing an 87 Turbo Coupe

Reply #11
Cranked but did not start.  MSD 6A is DOA.  Made good progress though.

Saturday morning finished connected all the fuel lines and reinstalled the tank.



Unfortunately turned it on and once it pressured up gas came running down from the top of the tank.  Dropped it down, saw it dripping from the supply fitting to the hat, redid the fitting, tried again.  Nope, was actually coming from the hose itself, about 8" up.  That braided ptfe hose was the one that has been on the car since 2012ish, dunno if that piece had been up against something hot (I pulled it off and rerouted everything since not using a sump anymore) or what was going on.  Dug around in the stash and turned out to have a union, so pulled that hose back out (ugh), cut it off, redid the end and built the piece to replace the bad section.



Got it back on, pressured everything up again.  Once it pressured up, carb sprung about 8 different leaks, all the gaskets had gone bad.  At that point had been going 13 hours straight without eating so cleaned everything up and called it a night.

Sunday morning got up, moved all the vehicles out, and spent a couple of hours sweeping, mopping, putting all the tools away from the whole process, sorting through leftover bolts clips etc, and generally organizing everything that's accumulated.

I'd had the false floor out of the trunk to access the fuel pump wiring so got it all put back in and cleaned up.



Then pulled the carburetor off and went over to my dad's to go through it.



Back together.





Had one hiccup with one of the needle valves sticking and gas fountaining up about 4 inches high out of the fuel vent, got that fixed, then the clear sight plugs in the bowls both broke off from age so replaced those, and were ready to give it a shot.

We pulled a valve cover, primed the oil pump, and gave it a shot.  Cranked fine but didn't try to fire.  We played with the distributor, then checked spark and nothing.  Like so many other things, guess sitting hasn't been kind to the MSD. 

Tonight we'll pull it and the MSD distributor and swap to one that doesn't use an external box and give it a shot again.