Skip to main content
Topic: Proper injectors for stock Speed Density 5.0 (Read 6200 times) previous topic - next topic

Re: Proper injectors for stock Speed Density 5.0

Reply #30
You will be "over fueling" if the vacuum is not getting to the fuel pressure regulator.
As the vacuum goes up, the fuel pressure is supposed to go down.

Re: Proper injectors for stock Speed Density 5.0

Reply #31
Can indicate which category the codes are in?  KOEO, Memory or KOER

Re: Proper injectors for stock Speed Density 5.0

Reply #32
Yes, i will recheck the codes and categorize them, sorry for the delay
1988 Cougar LS - Cinnabar/Rose Quartz Metallic two tone - 3.8 V6 - Rescue
1988 Cougar LS - Cinnabar/Rose Quartz Metallic two tone - 5.0 V8 - Survivor

Re: Proper injectors for stock Speed Density 5.0

Reply #33
Did the test again...

KOEOFF - 11

MEMORY - 91
                  - 41

KOER - 4

Not sure why last time i got so many engine running codes...also some of the old memory codes must have been forced out, because the 91 and 41 codes were stored 3 times each.

1988 Cougar LS - Cinnabar/Rose Quartz Metallic two tone - 3.8 V6 - Rescue
1988 Cougar LS - Cinnabar/Rose Quartz Metallic two tone - 5.0 V8 - Survivor

Re: Proper injectors for stock Speed Density 5.0

Reply #34
Did you stop the KOER before it finished?
It post the engine code, 4 for 8cyl engine, then runs the tests.
If the tests found no problems it should have posted  code 11.

Re: Proper injectors for stock Speed Density 5.0

Reply #35
waited quite a while after the '4', nothing followed.  Also it seems that the engine was running super high idle when i had the test jumper hooked up, because when i unplugged it, the idle dove.

Probably related, not only is the exhaust reeking of fuel and black, but it's also now spewing out black condensation that's staining my garage and driveway.  I have it on good authority that my cat is clogged up, and now its fouled my O2 sensors and dumping even more fuel in.  The fact that I removed the smog system probably accented the problem. 
1988 Cougar LS - Cinnabar/Rose Quartz Metallic two tone - 3.8 V6 - Rescue
1988 Cougar LS - Cinnabar/Rose Quartz Metallic two tone - 5.0 V8 - Survivor


Re: Proper injectors for stock Speed Density 5.0

Reply #37
The smog pump (thermactor) system not working will not cause your problem.
Is it possible your smog delete procedure screwed up some other systems? Give us the details of your smog delete and maybe we can spot something.

Yes, running rich can cause the cats to overheat and eventually ruin them.

Your idea that the O2's getting carboned-up and causing the EEC to dump in more fuel, I'm having trouble with that theory.
The O2 measures the difference in oxygen content between the exhaust and the ambient air.
A big difference means rich and a small difference means lean. If the sensor is carboned over so it can't sense anything, this would be a big difference and the EEC would cut back on the fuel.

KOER does change the idle speed as part of it's tests.

Check your fuel pressure. The no vacuum pressure is 39 psi.
 
Let KOER complete it's tests.


Re: Proper injectors for stock Speed Density 5.0

Reply #38
How's the fuel pressure regulator?

When those go bad, it will make it run shiznit-rich and do what you are describing. Also no/low vac to the FPR will pretty much do the same.

Like softtouch says, the cats being (potentially) plugged up has NO bearing on the eec "telling" the injectors to pulse in more fuel..that will NOT happen on this eec system...

As mentioned, I'd test fuel pressure, then vac at the FPR if it's suspect (and in my opinion it sure as hell is), and Foe's point is valid too about spraying carb cleaner around the intake and such.

Possible you have a torn or cracked hose on the bottom of the upper? When I did the Cobra intake on mine, one of those hoses was cracked from being on the shelf for a time before I got it and with the engine running, it would open up and make it act plumb silly.

Vac gauges are worth their weight in gold coin, though you still have to the leg work to find where the leak(s) hang out...

But my $ is on that FPR...
'84 Mustang
'98 Explorer 5.0
'03 Focus, dropped a valve seat. yay. freakin' split port engines...
'06 Explorer EB 4.6

Re: Proper injectors for stock Speed Density 5.0

Reply #39
I'm also leaning towards the map sensor or a vacuum leak. Having 19-20 at idle should be in spec. An easy way to test it,, as well as a base idle reset.

With the car running, unplug the iac. The idle should barely change. How I adjust it, I turn down the idle screw until it starts to buck or have a hard time idling, then I plug it back in. Thats it.

If you have a bunch if vacuum leaks, then you will not be able to lower the idle enough the car might die.

The reason I bring this up, if the iac is unable to control the idle, the car will try to compensate by messing with timing and fuel. This causes all kinds of issues.

If you can get the car to almost die, then the iac is able to perform it's job, and you really don't have to worry about vacuum.

However, I would check the plastic vacuum manifold. These 5.0's like to eat motor mounts. I've had a few where they started surging and gas mileage went way down. Either that plastic manifold was broken/cracked it the hose had a hole. This is the main vacuum distribution for the whole engine.

You need to verify that the mao sensor is indeed getting the same 19-20ish vacuum at idle. If that's all good and you are able to do the iac reset like I said, I would feel pretty good about saying that the map sensor is probably bad.

As far as the cats go, they usually only last 7-10 years and about 100-150k miles. Almost every one of these cars I've seen, the cat is either completely hollow, it blowing honeycomb out the exhaust. I even passed emissions with 291k miles on a car that had a very annoying rattle. The rattle ended up being a round chunk of cat material that bugged me for years. It was about the size of a golf ball, just bug enough to not go through the exhaust opening in the cat.

One day I replaced the rusted out tail pipe, when I dropped it, a little ball came rolling out and my rattle was gone.
Quote from: jcassity
I honestly dont think you could exceed the cost of a new car buy installing new *stock* parts everywhere in your coug our tbird. Its just plain impossible. You could revamp the entire drivetrain/engine/suspenstion and still come out ahead.
Hooligans! 
1988 Crown Vic wagon. 120K California car. Wifes grocery getter. (junked)
1987 Ford Thunderbird LX. 5.0. s.o., sn-95 t-5 and an f-150 clutch. Driven daily and going strong.
1986 cougar.
lilsammywasapunkrocker@yahoo.com

Re: Proper injectors for stock Speed Density 5.0

Reply #40
The MAP sensor performs the same function as a MAF would if you had one, but it bases it off of VACUUM MEASUREMENT.  I hate that you can't monitor a datastream before 92, because we could just compare actual to measured.  Failure mode example:  idle vac actual is 20.5 inhg, but MAP is bad, so MAP is saying it's 13.9 inhg.  Is this scenario, you have good vac, but since the MAP data to EEC is bad, EEC's load calc is also bad. (garbage in, garbage out) EEC advances timing and adds fuel for power enrichment, meanwhile, TP has not changed, and HEGO is pegging rich.  Rich HEGOs in power enrich mode is not unexpected, but 1.0v ish from TP may or may not flag a fault.
On-board sensor diagnostics is hard for EEC4, especially when you're talking about close-range or in-range failures. MAP, doubly so, because MAP is one of the sensors that most on-board sensor diag relies on for known value assumptions. 
Most MAP diags i've done in the past 10 years have been GM, because they use it in conjunction with MAF while Ford dumped it completely for MAF, and I just don't see those cars vary much.  If we had access to an appropriate year PC/ED manual, we could test using reference values (sensor output voltage relative to vacuum measurement).  A known good sensor from the parts store is cheaper that a PC/ED or access to one, so Before you chase those balloons any further, try a known good MAP.

Re: Proper injectors for stock Speed Density 5.0

Reply #41
Part of the reason vac leak issues are so problematic on SD cars is that if vacuum is leaking, not only do you have the issues that come along with a vacuum leak, but you also now have a skewed MAP value.  On GM cars, we'd use that fact as a preliminary confirmation of any suspected vacuum leakage.

Re: Proper injectors for stock Speed Density 5.0

Reply #42
Did you remove the vacuum to the thermactor solenoids?
If so, maybe you inadvertently also removed the vacuum to other stuff. MAP sensor, fuel pressure regulator etc.

Re: Proper injectors for stock Speed Density 5.0

Reply #43
After re-reading the whole thread, your fuel pressure checks in post #9 indicate the regulator has vacuum and is working  fine.
Sorry, I'm an old coot and can't remember what I read back in June.

Re: Proper injectors for stock Speed Density 5.0

Reply #44
Sorry I've been absent from this thread for the last few months, been caught up in another project.

I decided to test my exhaust/cats/O2 sensor theory a few weeks ago, mostly because I wanted to upgrade anyway.  I put headers on, 2 high-flow cats, 2 new O2 sensors, and an X-pipe, and took out each of my plugs, cleaned off the fouling, and re-installed.  Also disconnected the battery for a few days so the computer could reset itself. 

Ran the car for about 20 minutes today; for the first 10 minutes it ran fine, then it started spitting, which I could hear easily because I don't have lers on yet.  Then, a few minutes later, it started surging again.  No CEL, and it didn't stall, but still surging nearly as bad as before. 

My theory now is that it was still running rich, and took 10 minutes to foul up the plugs again and start really running poorly again.

My next ideas are to use brake clean/carb cleaner to test for vacuum leaks (although I checked the vacuum pressure, why not try anyways), and change plug wires (I put a high-end MSD coil on it last year to try to solve the problem, but i still have stock motorcraft 7mm wires, perhaps they are old and/or can't handle the hot spark from the uprated coil)

I'm hearing the MAP sensor come up often in your recent replies, is it something I should consider testing/replacing?
1988 Cougar LS - Cinnabar/Rose Quartz Metallic two tone - 3.8 V6 - Rescue
1988 Cougar LS - Cinnabar/Rose Quartz Metallic two tone - 5.0 V8 - Survivor