Skip to main content

Topics

This section allows you to view all Topics made by this member. Note that you can only see Topics made in areas you currently have access to.

Topics - Mikey97D

1
Electrical Tech / Fuel Pump Runs Intermittently
'88 Thunderbird TC

About a month or so ago I thought my fuel pump went bad so I replaced it with a Walbro 255 lph that I had waiting to install.  Ran fine for a few hundred miles until yesterday 1/2 mile from home.

Replaced the TFI cause it was erratic on running / not running yesterday.  Thought I was gonna need a tow but it started and ran perfect to get it home.

I tried to warm the car up to set the timing after replacing the TFI (It's easier to remove the distributor to change TFI on the 2.3).  Runs for a few minutes and dies.  Timing light is flashing so I know I have spark.  Fuel pump does prime when i turn the ignition on for starting.  Doesn't prime every time I cycle the key back to back. 

I get the car to run for a few moments to see the fuel pressure at 35 psi at idle then drop and the car dies.

I found the inertia switch and the white button is floppy.  Doesn't seem to do anything either direction. 

The intermittent thing has me thinking it isn't the inertia switch, but not sure.  Should the button be floppy on the switch?
What next to check?

Thank you in advance.
2
Body/Appearance/Interior / Trunk lids - Thunderbird & Cougars
I am guessing the trunk lids are different between the Cougar and Thunderbird?  Is the Cougar similar to a Mustang lid?

Is the '87-88 Thunderbird lid different from the previous years?

A friend in the Foxbody club makes interior covers for the Mustangs and just picked up my extra trunk lid to setup on.  He's going to put the Thunderbird image I have on my wheels into it too.

I am going to start bugging him about hood insulation after this......
3
Suspension/Steering / Brake Fluid Contaminated Pads
Unfortunately, it looks as if my re-manufactured rear caliper on the driver side sprung a leak and now the Hawk pads on that side are soaked.  It is DOT 4 brake fluid not sure if it makes any difference. 

If I didn't spend the extra coin on these pads I would just replace the pads, but curious if the Hawk pads can be cleaned.  I see online that the brake fluid is water soluble and the puddle in my driveway cleaned up well.  I am just not sure how long it has been leaking since I oddly don't notice a brake pedal feel change.
4
Show Photos / Foxbody Club of Connecticut Cruise 5/24
My son and I attended the Foxbody Club of Connecticut cruise this past Sunday. 
All the cars there were Mustang/Capri's with one LTD Station Wagon and then us in the TC.

5
Engine Tech / Vacuum Hose Adapter
I have been chasing vacuum leaks and a smoke machine was a real saver. 

There is a rubber adapter that connects the boost gauge hose to the vacuum that is very dry rotted on my car.  I need to replace it and unable to visit the autopart stores as of right now.
Anyone replace this before?  I have searched around online, but I think my vocabulary for the search is incorrect.
I have temporarily safety wired it in place.  I am going to need it for the hose that runs to the HVAC and EGR controller too.

Or is there a better way to go about this than replacing that adapter?

Thanks!

6
Engine Tech / Aeromotive Fuel Pump
Looks like there is a sale going for these in the Stealth 340 series.  Has anyone used them?

From the chart for fitting they don't list our cars so do we look under Mustang 85-97 (Except Cobra)? 
P/N 11540: 340 Fuel Pump, Center Inlet

I bought a rail, injectors, fuel regulator (Aeromotive) , and gauge off someone on FB.  Having the injectors cleaned and rebuilt now.
7
Engine Tech / Exhaust manifold - 2.3
A previous owner decided for me to make the EGR inoperable.


I didn't think I had enough map gas to get it out so I went to a shop to get the fitting out.  I've found a 1/2 npt steel plug at Home Depot. 

My question is do I need to seal the plug with something other than just threading it in?
9
Engine Tech / '88 2.3T breaking up
Recently on long hills in 3rd near WOT and about 10psi of boost the car starts "missing".  Does not do it in the other lower gears and have not noticed it in 4th or 5th.

The plugs have about 3000 miles on them.  I have another set to put in when I go to check.  I was originally thinking maybe the gap was too big and lower it.  Second guessing myself now that maybe I am running out of fuel?  I am on the original size pump.

Thoughts on what else to check?
10
Other Vehicles / '16 F150
Picking up this used truck today.  Getting anxious.

'16 F150 XLT Crew Cab with 6.5' Bed.  38k miles.  I hope it treats me well.
11
Suspension/Steering / '88 Turbo Coupe optimizing the stock brakes?
I am not ready yet to do a 5 lug swap and remove the TEVES.  Maybe in a couple years.

The brakes in my car feel "vague" is about the only way I can describe it.  The pedal doesn't give much feedback what is going on.  I have done a couple emergency stops but the wheels didn't lock up so I assume the ABS works, but I didn't the clatter of it turning on either.

The rotors and pads look fairly new on the car, but I am not opposed to swapping them out.  I am planning on bleeding the brakes, replacing the pins in the front and find the shims for the pads if any. 

Any suggestions on what else to do other than bleeding the lines?  Maybe some other pads? 

Thanks!
Mike
12
General Fox T-Bird/Cougar Discussion / Rust Remover
There's several products out there for removing rust.  I would like to see what others have used to see before and after results.

For smaller parts that I can fit in a coffee can/bucket I have had good success with Evapo-Rust.  The hardware shown is off my old dirt bike that was in a damp garage that I soaked over night in the Evapo-Rust.

Before:




After:






I did need to paint/protect the parts after the chemical treatment or they would rust up pretty quickly.

I am curious on other products for larger parts like the Rusty 911 that Chuck mentioned in another thread.
13
Engine Tech / 2.3L Wastegate / Turbo spring modification?
My Father and Step mother were the previous owners of my '88 TC.  My father had a mechanic change the cam to a roller setup and later I found out he also modified the car to create more boost.  He also turned the boost alarm off.

I took ownership of the car last January and got it running again.  Stuck fuel injectors and other odds n ends to get it running fairly well.  I replaced vacuum lines that were dry rotted, etc.

I wanted to adjust the turbo pressure so I purchased a Gilles Valve from all the recommendations I have read.  This is when I found out the someone had mickey moused the turbo setup.  Right now I have the no spring or ball in the valve and it produces 18 psig boost.  I have checked for a vacuum leak and have not found any (Not that there isn't any, but I have not found any).  I placed a vacuum gauge on it in the summer and the vacuum sits between 14 & 15 psi depending on the idle.  The idle does vary sometimes as if a module is adjusting the rpm.

The idle does hang sometimes when I push the clutch in and other times it does not.  I have not figured out what causes this.

It appears I my commuter car may be taking its last breathe and until I find a replacement the Thunderbird may have to fill the slot for a time.  At this point in time with the turbo set the way it is the car is a handful in the rain.  It hits like a '70s era 2 stroke dirt bike.  All off or on in the power band.  I would like to turn the boost down. 

I hate the thought of exposing the car to this salt brine they put on the roads, but......
14
User Rides / Work In Progress. '88 TC
This is my '88 Turbo Coupe.  I've been lurking around here trying to get up to speed.  I am still a long way off.

Not a lot of options in this car.  I have been working on it slowly trying to get it up to snuff.






I've taken the airbox out and put an open element on it.  Added a Gilles Valve too, but there are some problems there with the boost control. 


When I got the car a couple of the injectors were stuck open and the fuel tank was full of junk.  New fuel tank and rebuilt injectors and she is back up running.  Idle hunts around as if it has a big cam in it but I think that is one of the sensors needing adjusting.  It does have a roller cam (-4°).  Needs an exhaust soon plus a refresh on the suspension & brakes. 

Here was my 2nd TBird from a long time ago.