Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Need info on a 92 Thunderbird 5.0 H.O.

  1. #11
    Join Date
    Oct 2004
    Location
    Utah.
    Posts
    9,023
    Feedback Score
    2 (100%)

    Default

    Not only that, outside of emissions crap which you probably won't want/need, there really isnt much that needs to be hooked up.
    Quote Originally Posted by jcassity
    I honestly dont think you could exceed the cost of a new car buy installing new *stock* parts everywhere in your coug our tbird. Its just plain impossible. You could revamp the entire drivetrain/engine/suspenstion and still come out ahead.
    Hooligans!
    1988 Crown Vic wagon. 120K California car. Wifes grocery getter. (junked)
    1987 Ford Thunderbird LX. 5.0. s.o., sn-95 t-5 and an f-150 clutch. Driven daily and going strong.
    1986 cougar.
    lilsammywasapunkrocker@yahoo.com

  2. #12
    Join Date
    Oct 2017
    Location
    Illinois
    Posts
    8
    Feedback Score
    0

    Default

    As of today, I do plan on reworking the factory TB harness to work in my truck. My truck had an ecm in it originally, so wiring up power to the harness should have the same protections built-in as the original truck harness would. All factory wired through the fuse box. I already have both EVTM's and a Ranger 5.0 swap book as well.

    I've already removed the air pump, and the piping across the back of the heads. Plugged the holes in the heads too. The EGR valve has been removed and a homemade cover plate installed. There were no coolant lines to deal with in my case. I also picked up a belt to run the engine accessories and bypass the smog pump.

    I'm sure I'll have lots more questions along the way.

    Thanks everyone for the info so far.


    GB

  3. #13
    Join Date
    Oct 2017
    Location
    Illinois
    Posts
    8
    Feedback Score
    0

    Default

    Hey all, another quick question for you if you don't mind. So far, from what Google has shown me, my problem is normal and nothing to worry about.

    On the 1992 5.0 power steering pump, the hard line can still rotate freely after tightening the fitting. It doesn't seem like it'll seal but I've read it somehow seals under pressure?

    Any thoughts? Anything to look out for? There was no plastic ring on the factory threaded fitting (pump end) like the other end of the line had. Am I stuck with buying another line that has the plastic ring on it? I sure hope not because I already built my custom line from this factory one, and those are expensive to build. The ring seems far too thin to actually seal much anyway...?

    GB

  4. #14
    Join Date
    Oct 2017
    Location
    Illinois
    Posts
    8
    Feedback Score
    0

    Default

    I picked up a new "teflon" sealing ring today for the high pressure line where it threads into the pump. Although I figure it'll make the pressure line spin/rotate even easier. I'm saving it for final assembly.


    GB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •