Page 7 of 8 FirstFirst ... 345678 LastLast
Results 61 to 70 of 77

Thread: Back in a fox. 1988 Turbo Coupe. The life journal.

  1. #61
    Join Date
    Oct 2004
    Location
    Pasadena, MD
    Posts
    7,415
    Feedback Score
    7 (100%)

    Default

    So it's been too long since I've made an update. Unfortunately, it's because there hasn't been much to update.

    I haven't done much with the car other than drive it. I did get into a "speed altercation" with my co-worker in a 2016 Ecoboost Mustang. I ended up walking him by about 2 cars at double the posted speed limit in Mexico. I honestly think there is something wrong with his car, but it's been fun having the entire shop in his ass over it.

    This is the busiest time of the year at work and with the social life, so cars have taken a back seat. My garage is full of Christmas crap so not much has gone on there. We are hosting a big Christmas dinner at my house in which I'm not pleased about, and we just hosted a party this past weekend where I learned that shot glasses fit in the garbage disposal.

    I have managed to score an okay deal on some Maximum Motorsports front control arms. It would have been a screaming deal if the balljoints were in good shape. The boots are missing, and the grease is contaminated. I'm hoping I can drill and tap for a grease fitting and push all the garbage out. They also need new bushings, which I'll probably replace with delrin.



    We just recently got a few inches of snow here in Maryland. While it's unfortunate that I couldn't get the car in the garage for the winter, it did make for a nice photo op.

    I'm also bad for randomly buying toys that take away from my car funds. Prime example:



    It's a 1/5 scale Redcat Dunerunner. Has a 30cc gasoline engine on it. I bought it used with a few problems I didn't know about. First run and I broke a left front shock, and found that the front driveshafts were missing. I have those coming, in addition to a bunch of hardware that was vibrated loose. It'll do about 40mph, which isn't all that fast, but it will eat up a lot of real estate really fast with how big it is.
    It's Gumby's fault.

  2. #62
    Join Date
    Jun 2005
    Location
    Chicago
    Posts
    10,616
    Feedback Score
    17 (100%)

    Default

    Snow is just frozen water. Letting it outside isn't the best but, as long as you don't drive it with salt on the roads you're not doing any permanent damage.

    Are you going coil over in front? You need to in order to use the MM front control arms: http://www.maximummotorsports.com/MM...tang-P389.aspx
    '88 Thunderbird LX: 306, Edelbrock Performer heads, Comp 266HR cam, Edelbrock Performer RPM intake, Edelbrock 70mm TB, 76mm C&L MAF, 30lb injectors, 2.5" exhaust, AOD with 2800 PI converter, 8.8 with 3.73 gears, 31 spline Traction-Lok, 31 spline Moser axles, 04 Cobra front arms, Maximum Motorsports extreme duty rear arms, subframes.
    '11 Focus, '12 Mustang 3.7, '17 Accord EX-L V6

  3. #63
    Join Date
    Oct 2004
    Location
    Pasadena, MD
    Posts
    7,415
    Feedback Score
    7 (100%)

    Default

    I'm not going coil over yet. I found the arms in a Facebook groups for 145 shipped. The guy thought they were a different companies product. I just stuffed them in the stash for the time being. I have SN95 springs and some inexpensive shocks and struts I'll be using for a little while.
    It's Gumby's fault.

  4. #64
    Join Date
    Jun 2005
    Location
    Chicago
    Posts
    10,616
    Feedback Score
    17 (100%)

    Default

    For $145 Why not. Stash them until they are needed.
    '88 Thunderbird LX: 306, Edelbrock Performer heads, Comp 266HR cam, Edelbrock Performer RPM intake, Edelbrock 70mm TB, 76mm C&L MAF, 30lb injectors, 2.5" exhaust, AOD with 2800 PI converter, 8.8 with 3.73 gears, 31 spline Traction-Lok, 31 spline Moser axles, 04 Cobra front arms, Maximum Motorsports extreme duty rear arms, subframes.
    '11 Focus, '12 Mustang 3.7, '17 Accord EX-L V6

  5. #65
    Join Date
    Mar 2006
    Location
    Guilderland, NY
    Posts
    3,451
    Feedback Score
    11 (100%)

    Default

    Oooooooooh 1/5 scale GAS BUGGY.

    If I ever get another R/C it'll be one of those. Had a Traxxas nitro one, was fun but I always longed for that simplicity. And cheaper fuel LOL
    1987 20th Anniversary Cougar, 302 "5.0" GT-40 heads (F3ZE '93 Cobra) and TMoss Ported H.O. intake, H.O. camshaft
    2.5" Duals, no cats, Flowmaster 40s, Richmond 3.73s w/ Trac-Lok, maxed out Baumann shift kit, 3000 RPM Dirty Dog non-lock TC
    Aside from the Mustang crinkle headers, still looks like it's only 150 HP...
    1988 Black XR7 Trick Flow top end, Tremec 3550
    1988 Black XR7 Procharger P600B intercooled, Edelbrock Performer non-RPM heads, GT40 intake AOD, 13 PSI @5000 RPM. 93 octane

  6. #66
    Join Date
    Oct 2004
    Location
    Pasadena, MD
    Posts
    7,415
    Feedback Score
    7 (100%)

    Default

    Quote Originally Posted by ZondaC12 View Post
    Oooooooooh 1/5 scale GAS BUGGY.

    If I ever get another R/C it'll be one of those. Had a Traxxas nitro one, was fun but I always longed for that simplicity. And cheaper fuel LOL
    Don't do it. It's the worst hobby ever. Parts aren't expensive, until you decide to build something. Those 5-12 dollar parts add up fast!

    Honestly, electric is the way to go now. With brushless motors and LiPo batteries, they're faster and easier than nitro. This gas buggy does maybe 37-38mph, which isn't that fast. I have a 1/8 electric buggy out of the box that is just as fast, and with gearing and programming the ESC, I can get about 50mph out of it.
    It's Gumby's fault.

  7. #67
    Join Date
    Oct 2004
    Location
    Utah.
    Posts
    9,167
    Feedback Score
    2 (100%)

    Default

    Electric is definitely the way to go. I can get almost double the perfomance out of a Lipo that I can out of a gas engine on my model airplanes.
    Quote Originally Posted by jcassity
    I honestly dont think you could exceed the cost of a new car buy installing new *stock* parts everywhere in your coug our tbird. Its just plain impossible. You could revamp the entire drivetrain/engine/suspenstion and still come out ahead.
    Hooligans!
    1988 Crown Vic wagon. 120K California car. Wifes grocery getter. (junked)
    1987 Ford Thunderbird LX. 5.0. s.o., sn-95 t-5 and an f-150 clutch. Driven daily and going strong.
    1986 cougar.
    lilsammywasapunkrocker@yahoo.com

  8. #68
    Join Date
    Oct 2004
    Location
    Pasadena, MD
    Posts
    7,415
    Feedback Score
    7 (100%)

    Default

    Quote Originally Posted by Haystack View Post
    Electric is definitely the way to go. I can get almost double the perfomance out of a Lipo that I can out of a gas engine on my model airplanes.
    And no mess, no tuning, no fumes, no glow plus, no spark plugs, no receiver batteries, no mixing fuel, no pistons and sleeves...

    But, I do really enjoy this 2-stroke. It does have a neat wow-factor. I have a nitro car I need to rebuild, but I just haven't gotten around to it. Everything else I have is electric
    It's Gumby's fault.

  9. #69
    Join Date
    Oct 2004
    Location
    Pasadena, MD
    Posts
    7,415
    Feedback Score
    7 (100%)

    Default

    It's getting to be that time of the year. Finally getting off of my lazy ass and getting a little bit of work going.

    This past Saturday, I spent about an hour cleaning the garage. It pretty much got over run with stuff that't supposed to go in the shed, or never quite got a winter home. I didn't get it organized or anything, but I did free up enough room to work.

    A gentlemen by the name of Heath has designed some motor mounts for the 86-88 Turbo 2.3 cars. He sent out a few prototype sets of mounts for a discounted rate for people to test. I was the last person to receive the mounts, yet I am the only one to get them installed so far.



    The mounts do bear a strong resemblance to Chucks mounts, but they aren't remotely the same.

    I started off trying to take a bunch of pictures to do a How-To type ordeal, but it's hard to stop what you're doing to take pictures.

    But anyways, I had to jump start the car, so I had it running while I finished moving some stuff out of the garage. Drive it halfway in and put it on ramps. I laid under it, and looked at the drivers side mount and remembered that it wasn't very pleasant.



    That's not too bad.


    Those two aren't bad either.



    That's the cheeky little bastard that's a pain in the ass.

    Long story short, all of the bolts came out easily, other than that front bolt. I had to use an open end wrench, and when the bolt backed out, it would back against the isolator. In the mean time, my jack crept down and put pressure on the mount. I didn't realize that I didn't have the valve completely closed on the jack.



    I had the jack under the bellhousing with some scraps of wood bridging the pan and the bellhousing.



    There's the new mount and the old mount.



    I knew that bastard was broken.





    New mount in.

    So at this point, I stopped taking pictures. The installed pictures were actually after I had finished and was getting ready to take the car out.

    The passenger mount was actually a bigger pain in the ass than I expected. Part of it is my fault. I tried to do the mounts one-at-a-time. With the drivers side mount installed, there is very little flex to get the engine jacked up. I had to unbolt the drivers side mount from the k-member to get the engine jacked up. Even then, I was wrestling the old mount trying to get it out. I then realized why I remembered installing Chucks mounts was so much easier 10 years ago...I ripped the A/C out of my cars! I actually had to prop the mount up at a wonky angle, and remove the two 10mm bolts to get the mount plate off of the isolator.

    Installation was much easier. The mount almost fell into place. I did have to fight and play with angles to get the bolts to start, and there was very limited finger room for the front bolt. I discussed elongating the front hole a bit with Heath to maybe make it a little easier to install.





    Passenger mount installed.

    Once Heath gets all of the feedback, he is going to make some revisions and send new powdercoated brackets and hardware. When I do this job again, I am going to do things a little differently. First, I'm going to loosen all of the bolts. Then, get the jack set up and remove the crossmember bolts. At this point, I can jack the whole engine up, slide each mount out, and then set the engine back down.

    So how does it drive? I wish I knew!

    I cleaned up and went to test drive the car. Start it up, and it died after 2 seconds. I know it's low on gas, but I had it running even on the ramps. I fired it up again and it did the same thing. I tried to use the throttle to keep it running, but it dies as if the key is shut off. At this point, I fired it, revved it up and hopped it off of the ramps before it died. My two thoughts is that I may have broken or damaged the ground on the accessory bracket by the drivers side motor mount, or smacked the TFI and made it stupid. I had tach signal, so I feel that the TFI is at least "working". My girlfriend was going to help me just push the car back outside but she was finishing up dinner, so my curiosity got the best of me. The Trans Am barely fits in the garage, and the TC is 9ish inches longer. After I almost pushed it out of the door, I drug it back in.



    The damn things fits! I have about 4" from the front license plate to the wall, and about 8" behind it to the door.

    I hooked up my battery charger/tender, and will get back to diagnosing the running issue another day.
    It's Gumby's fault.

  10. #70
    Join Date
    Oct 2004
    Location
    Dunnville Ontario Canada
    Posts
    2,991
    Feedback Score
    1 (100%)

    Default

    Good to see you making some progress Shawn.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •