Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: ignition coil replace?

  1. #11
    Join Date
    Oct 2004
    Location
    Huntsville, AL
    Posts
    2,053
    Feedback Score
    2 (100%)

    Default

    My timing chain was stupid stretched and it still ran fine. 260k miles on it.

  2. #12
    Join Date
    Mar 2015
    Location
    braintree ye olde england
    Posts
    123
    Feedback Score
    0

    Default

    Ok I'll leave the timing chain for now just had my yearly mot and failed on high co2 emissions 5.3% (4.5%max).smog pump bypassed and de-cat.changed the oil,air filter is clean and ignition timing spot on.only thing I can find out of spec are both injectors show 2.4ohms a little higher than they should be.both tests show 11 pass.changed the o2 sensors since last year's test(4.1% pass).don't know what else I can do to get the level down.

  3. #13
    Join Date
    Oct 2004
    Location
    East Coast Virginia
    Posts
    10,156
    Feedback Score
    0

    Default

    Quote Originally Posted by mr glee View Post
    Ok I'll leave the timing chain for now just had my yearly mot and failed on high co2 emissions 5.3% (4.5%max).smog pump bypassed and de-cat.changed the oil,air filter is clean and ignition timing spot on.only thing I can find out of spec are both injectors show 2.4ohms a little higher than they should be.both tests show 11 pass.changed the o2 sensors since last year's test(4.1% pass).don't know what else I can do to get the level down.
    Fix the smog pump and install a cat, it'll likely pass emissions... May pass with just the pump reconnected, though once it's known the cat is gone, they'll probably can you on a visual... Don't worry about injector resistance, they vary somewhat and aftermarket rarely are same as orig...






    My other rides (that actually do run & drive)

    1969 Fairlane Cobra 428CJ 4-Speed

    1972 Comet GT - 306 C4

  4. #14
    Join Date
    Mar 2015
    Location
    braintree ye olde england
    Posts
    123
    Feedback Score
    0

    Default

    Smog pump is now back on and the death rattle is back.car is pre-cat regulated due to its age and it passed​ it's last two mot's with smog bypassed and decatted 2015 3.57% 2016 4.1%.when it had the cat and smog running it was 0.14% .retest on Monday will find out then.

  5. #15
    Join Date
    Mar 2015
    Location
    braintree ye olde england
    Posts
    123
    Feedback Score
    0

    Default

    Just passed the emission test was co 5.3% with smog pump connected now 0.24% very happy with that now to take it off again as bearings are badly worn I need it for next year thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •