PDA

View Full Version : Strange Downshift....



MexCougar
07-24-2005, 07:51 PM
Well, yesterday i took the car for a little ride. When i was cruising at 80km the tranny downshift to 2, and i wasnt acelerating, and was at a plain road. Well, the car stayed at second, and i kicked to 2, and getting again to D, and the car got 3 without problems. Well, no problem, but again i was cruising to 90 and the tranny dowshift again. Its very strange, since normally i don have tranny problems. Recently, i bought the tranny oil and get to a shop to do the change.
May i need to add a better oil and ditch that new oil ?

And remember, i have a C5....of course, the Kickdown cable is Ok.

http://usuarios.lycos.es/racingtrykes/almacen/Cougar.jpg

V8Demon
07-25-2005, 09:22 AM
Make sure your fluid is at the full mark. Even just a little low will cause it to shift weird.

MexCougar
07-25-2005, 02:45 PM
If i quit the Oil Pan of the tranny, how many liters (or pints) may i need to add ? Thanks

jcassity
07-25-2005, 10:45 PM
Start with 6 if you do the filter / fluid change. Make sure to check it when warm and running. Make sure that prior to checking the fluid level that you let it warm up and shift from P to R , D . this will get you a better fluid level reading.

MexCougar
07-27-2005, 02:08 PM
Well, i started with 6 pints, and the car didnt change. I add another pint and the car shifts very good. I took the car at this to do a test drive and drives good. The only thing is when i brake from, at least 60 km/h to zero the car shut off and i need to restart the car. Looks like i need to adjust the idle a bit, or i need to add another pint of fluid to prevent this ?

Thanks.