PDA

View Full Version : Wicked Chicken back at the track.



Lightningbird
04-19-2015, 11:23 PM
Finally got this thing back together and headed to Gainsville, Fl for some in depth tech and a few license passes. I got to make a 90% 1/8 mile pass and ran a 6.34 @ 106. I will try and get a video posted up of my first couple of license passes, keep in mind I cannot nail the throttle the entire track until my 5th and 6th passes for license requirements. I blew one of the cover gaskets out of my C4, that I believe is the 1-2 power piston, passenger side ....my shifter cable bracket is bolted to it. Maybe Tom can help me out here, no idea what it's called. Should have it replaced and back together by next weekend, then it's full on!

STANG8U
04-20-2015, 01:07 AM
Very nice hope to see some vids

Watched a few buddy's get there license

Lightningbird
04-20-2015, 10:23 AM
I meant the cover on the drivers side, not passengers side.

Pressure cooked chicken
05-04-2015, 04:45 PM
Any updates, Lightning? I know what cover you are talking about. I think it has an o-ring and a gasket.

Bad ass run for sure!

Lightningbird
05-18-2015, 08:23 PM
Sorry for the cliff hanger. I was in the process of moving to San Diego, Ca for yet another tour in the United States Navy. The last one was supposed to be my last, but there were too many good reasons to stay for another 4. This will take me out to 24 years active duty and will ensure I will not have to work for another man or woman again for the rest of my life after this tour.
I found that the o ring had pushed out the cover, so I pulled it off, cleaned it up and bolted it back together. I then headed for the track again the following weekend. After unloading the car at Gainsville, my buddy and I went to air the tires up in the front to 32 psi. We rolled the car backwards and the rear ended was popping. Definitely not good. Diagnosis, ring and pinion damaged. I was supposed to leave for San Diego the following Wednesday, so I towed it across the country and dropped it at San Diego gear and axle the next day after my arrival. Yup, ring gear missing 3 teeth. Had them swapped and changed to a 3.90 gear. I knew 4.10 was too much during my testing in Gainsville as I was getting into high gear at about 500 feet. I then hit Barona 1/8 mile strip this weekend! It ran a 6.33@107. I did pull a 1.31 short time and left tires up and in a hurry!

Lightningbird
05-18-2015, 08:45 PM
http://www.peteliebigphotography.com/Barona-Drags-2015/05-16-15-Saturday-Barona-Summit/i-6bhf6sZ.jpg

Lightningbird
05-19-2015, 11:53 AM
36479

Haystack
05-19-2015, 02:30 PM
I dunno how i missed this thread earlier.

That would be a 10 second flat 1/4 time if you have enough gear left.

thunderjet302
05-19-2015, 03:58 PM
That Thunderbird is moving a bit ;). Nice times.

Lightningbird
05-21-2015, 01:58 PM
Why is it upside down?

Lightningbird
05-22-2015, 10:19 PM
I'm not to savvy with pics on this forum, but I have no idea why the pic is upside down.