PDA

View Full Version : tourqe Converter problem??



CougarCoupe88
02-16-2005, 10:12 PM
OK let me start by saying this . 2 problem i think me and a friend have found the culprut. just want to get ur opinion on this .

the order of things how they went. 1. Bought my car 2. tranny goes bad. 3 swap AOD for another AOD out of a Cougar. while swaping Add a Trans go ShiFt kit. We didnt reinstall the stock mustang Tourqe converter bc we feard it may have been shot but we installed the cougars converter that i got the tranny from (drove the car myself it shifted) . 5. driev the car work out the bugs with the shift kit. ok fine 1 2 3 shifts fine hard and firm. great rite. not till OD. it feels like it neutrals then goes to od..

now what my buddy has come up with is that when it "neutrals" it's really the tourqe converter not able to keep up with the motor. bc it's a lower stall speed (Ment for a 3.8 Cfi Car and was much larger than the stock mustang one ) and when it does catch it's locking and then jaring every thing like when it catches . it grinds. which my guess is the imput shafts getting destryoed. and hurting the U jonint and some times the rear.

now that thats that problem but the car also seems to be a dog. before 2k and gets power rite up to 4k after that it's done. now could this be bc the converter not allowing it to breath. so im just thinking of getting a nice converter for the car now. .

any ideas. or more info let me know. and thanks for hearing me.

Erik

Haystack
02-16-2005, 10:48 PM
my car tops out just after 4000k....is it the stock camshaft?

Ifixyawata
02-17-2005, 01:11 AM
Sounds like something inside the tranny other than the convertor... I dunno. Unless, maybe the convertor is actually slipping at higher RPM, but usually once the convertor is at stall speed, it stays "stalled" as in both halves turning, from there on up.

dominator
02-17-2005, 07:19 AM
Look into the shift kit again,trans-go's have really bad instructions.
I toasted a trans with one,went back through the valve body 4 times,tried it in another trans and almost toasted that one too.
I really doubt it's your convertor,even the 3.8l should have atleast the same stock 1600 stall speed as your 5.0l on did.
Do a light brake toqgue and watch your tach if you have one to check approx stall speed.
Also od was a really bad gear for me when i put in the trans go,sometimes i had it sometimes i didn't,if you can get another stock valvebody and try it i would recomend it.
You'd be suprised how much a trans can get screwed up by messing with the VB.

TurboCoupe50
02-17-2005, 06:20 PM
What dominator said...


I can gaurentee you problem ain't the converter.. For 3rd and O/D power is transmitted through the small inner shaft, which is splined directly into the front hub of the converter. The stall of the converter makes no difference in these two gears.

CougarCoupe88
02-19-2005, 12:13 AM
well i guess b4 my cougar goes bye bye im gonna snag the tranny so i will have and extra stock vb. or an new used tranny to put back in. and when i pull the stangs tranny or just the T-go kit im gonna put all the high rev and hard shift stuff in . or do what you did TC50 bc i dont want WOT shifts to OD bc it's not designed for it. and if it still gives me crap in scraping the whole od thing together and gonna put a C4 in it .